HELP - Batteries Will Not Charge

Hi All: I recently gave my DJI Phantom to my 41 year old son. We tried to charge either of the batteries for the drone. No matter what we try, neither will charge. So, we bought an aftermarket charger and battery from Amazon. Same result. I may not be the smartest person on the planet but I’ve never considered myself the stupidest either. Any suggestions as to what we are doing wrong?

Hey @fewfamily5. Welcome.

As the owner of a few Phantoms for our business, I have seen something similar, particularly with batteries that sat due to the Phantoms being retired.

If you have tried different chargers and the issue is the same, the problem may be that the battery(s) went into hibernation mode, which is something DJI builds into their older batteries. When batteries sit too long, they hibernate. This prevents them from damage that occurs if they continue to discharge down to 0%.

IF this is your issue, simply having the batteries sit on the charger for a few hours will activate the battery (taking them out of hibernation).

See our article here for more information on Phantom batteries and issues that might keep them from charging: Phantom Batteries not Charging


Thanks Dan! I will follow the link in your posting and see what happens. Again, many thanks!

1 Like

You are quite welcome @fewfamily5. I hope that helps. If you ever have Phantom questions, feel free to ask away. We flew Phantoms in our business fleet for quite a while prior to retiring them. If they weren’t so attention-grabbing, I would have kept them.