DJI Mavic Air 2s & Litchi App Error Code Preventing Take Off

Interesting result after recent DJI Fly App update for iOs and Mavic Air 2s firmware earlier this week: With the Litchi app the Mavic Air 2s does not take off due to error code warning: “Error Code 180; Cannot Take Off; contact DJI Support”. The DJI Forum has a recent article on this situation (not the error code perse’) and this is what I have found. Air 2s and Litchi | DJI FORUM

Interested in other pilots who have experienced this after upgrade of firmware for the Mavic Air 2s. Article mentions update to the SDK for Litchi coming soon.

Solution to this issue tested and worked:

OK - I ran into the same problem after updating the DJI Fly App update and firmware update to the Mavic Air 2s. Litchi would not launch the drone at all. Here’s the work around until DJI corrects the bug with an update or Litchi developers become aware of the issue and resolve it on their end. Solution:
1, Start your drone with the DJI Fly app. Adjust your settings as you normally would before taking
2. Once the drone is airborne close the DJI Fly app and launch your Litchi app while the drone is
3. Bring up your Litchi mission (I usually create it through Mission Hub) and select the start feature.
4. Litchi worked fine as expected. This is a workaround until an update is pushed out from either
DJI and/or Litchi developers.

I’d like to hear from any pilots out there who have a different result.

Kind regards,

Excellent job, @MavRik, tracking this issue down. Although I have litchi installed on all of my devices, I never use it. This is great information to have for those folks that DO run Litchi. Thanks for the research.

1 Like

@Dan Thank you. Glad to at least find a work-around untl the bug is fixed by either party for sure! :blush: